0 Members and 1 Guest are viewing this topic.

*

KHDev

  • *****
  • 89
  • Releasing stuff and learning on the way!
    • KH Web Development
  • osDate Version: osDateEvo v1.2
Plugins Errors
« on: August 23, 2016, 01:17:58 AM »
Hey,

While working on my template i came across several issues with plugins and just thought i would post them in case they have fallen through the radar and to see if its just me who has the issues.


1. Advanced Compatibility Questionnaire
Errors on install (Input array has 0 params, does not match query)


2. Compatibility Questionnaire
 - Errors on install (Input array has 0 params, does not match query)
 - User-side jump to page options display error The user could not be found.
 - Answers don't seem to be saving

3. Advanced Hot or Not
- Best Of feature doesn't appear to flag users as best of (best of list is returning 0 results)

Might just be me but thought i'd check :)

*

Pharg

  • *****
  • 2,886
    • OsDateFourm
  • osDate Version: osDateEvo v1.2
Re: Plugins Errors
« Reply #1 on: August 23, 2016, 01:38:10 AM »
Hi KHD,

Yes that's correct, they do show some errors.

The plugins haven't been updated with the main script.  :-\

Most of the problems with plugins start when you use PHP 5.5 and up, they work fine in PHP 5.4 and PHP 5.3.

Also depends on some servers different settings being strict.
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

KHDev

  • *****
  • 89
  • Releasing stuff and learning on the way!
    • KH Web Development
  • osDate Version: osDateEvo v1.2
Re: Plugins Errors
« Reply #2 on: August 26, 2016, 02:11:41 PM »
Hey,

That explains it then since my test is on PHP 5.5


:)

*

heebeha

  • ***
  • 102
  • Me
Re: Plugins Errors
« Reply #3 on: December 20, 2016, 01:16:18 AM »
I am getting the same errors...    ???

*

Pharg

  • *****
  • 2,886
    • OsDateFourm
  • osDate Version: osDateEvo v1.2
Re: Plugins Errors
« Reply #4 on: December 20, 2016, 01:37:38 AM »
Hi Heebeha,

What error are you referring to in which plugin, need to know the details, can't just guess??
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

heebeha

  • ***
  • 102
  • Me
Re: Plugins Errors
« Reply #5 on: December 21, 2016, 02:39:55 PM »
Advanced Compatibility Questionnaire gives this error when attempting to install it in PHP 5.6

Input array has 0 params, does not match query: 'INSERT INTO dating_advcompQuest_content VALUES (283, "How important is your match's religion to you?", 16, 1)'

I have attached the errors below.


Compatibility Questionnaire gives these errors:

Input array has 0 params, does not match query: 'INSERT INTO dating_compQuest_content VALUES (466, 'How important is your match''s age to you?', 32, 1)'

I did not get any errors installing Advanced Hot or Not
« Last Edit: December 21, 2016, 10:12:38 PM by Pharg »

*

Pharg

  • *****
  • 2,886
    • OsDateFourm
  • osDate Version: osDateEvo v1.2
Re: Plugins Errors
« Reply #6 on: December 21, 2016, 10:14:59 PM »
Hi Heebeha,

I will look into these errors, in the mean time you can change your PHP 5.6 back to PHP 5.4 and these errors
will go away.

Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

Pharg

  • *****
  • 2,886
    • OsDateFourm
  • osDate Version: osDateEvo v1.2
Re: Plugins Errors
« Reply #7 on: January 26, 2017, 05:44:42 AM »
Hi members,


I have found what is causing the Input array has 0 params, does not match query: in the compQuest plugin and the advcompQuest plugin, it was the install.sql files in the plugins being out if date and where incompatible with the new MySQL DB versions on most hosts.

I will post the fixed plugins with the updated sql files soon.

 
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

heebeha

  • ***
  • 102
  • Me
Re: Plugins Errors
« Reply #8 on: March 23, 2017, 05:38:43 PM »
When are you releasing the fixes? 


Hi members,


I have found what is causing the Input array has 0 params, does not match query: in the compQuest plugin and the advcompQuest plugin, it was the install.sql files in the plugins being out if date and where incompatible with the new MySQL DB versions on most hosts.

I will post the fixed plugins with the updated sql files soon.

*

Pharg

  • *****
  • 2,886
    • OsDateFourm
  • osDate Version: osDateEvo v1.2
Re: Plugins Errors
« Reply #9 on: March 23, 2017, 08:31:05 PM »
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35