osDate Forum - osDate Dating Script

osDate => General osDate Help => Topic started by: mafabel on March 31, 2016, 07:11:47 AM

Title: Help on images
Post by: mafabel on March 31, 2016, 07:11:47 AM
Please my website image have different sizes some big some small is there a way I can make it all same size coz when on mobile phone some image will take over the screen and the site will not show properly on mobile even on web some image look big while some look small and solution to that?
Title: Re: Help on images
Post by: Pharg on March 31, 2016, 10:17:11 AM
Hi mafabel,

Can you give me a screenshot of what images you mean please?
And PM me your domain
Title: Re: Help on images
Post by: mafabel on March 31, 2016, 09:04:06 PM
Check your inbox pharg
Title: Re: Help on images
Post by: Pharg on March 31, 2016, 09:12:20 PM
Hi mafabel,

Yes I got it just now.

It's not a easy task, as it needs to be made responsive which the osDateEvo templates are setup to do.
To much to try and explain, you might have a to wait a few weeks or month to get the default template that's
already responsive.
Title: Re: Help on images
Post by: mafabel on March 31, 2016, 09:14:55 PM
OK good will I be able to use this templates am using with the osdate evo ?
Title: Re: Help on images
Post by: Pharg on March 31, 2016, 09:22:11 PM
Hi mafabel,

Check your email, little surprise there.
Title: Re: Help on images
Post by: mafabel on March 31, 2016, 09:25:12 PM
Will check now my email or my inbox here?
Title: Re: Help on images
Post by: Pharg on March 31, 2016, 09:29:14 PM
Your email :)
Title: Re: Help on images
Post by: mafabel on March 31, 2016, 09:36:52 PM
Whaooooooo!!!!! Got it thanks you are great this is more than little it a big surprise pharg
Title: Re: Help on images
Post by: Pharg on March 31, 2016, 09:37:48 PM
You are welcome :)
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 07:14:28 AM
One. Issue againi uploaded  a logo to the template and named it logo.png but its not showing on the site even the big banner too not working anything might caused that?
Title: Re: Help on images
Post by: Pharg on April 01, 2016, 08:03:38 AM
Hi mafabel,

That template was modded by another member but is no longer in here.

The logo is controled by the css files, but if you look in the images folder in the template, you will see the
image that loads, just put your logo in that image logo.png file and save.

It doesn't have the code for a uploaded image in it.
Title: Re: Help on images
Post by: Pharg on April 01, 2016, 08:05:03 AM
One. Issue againi uploaded  a logo to the template and named it logo.png but its not showing on the site even the big banner too not working anything might caused that?

Maybe remove the image you uploaded also.
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 08:07:20 AM
There is noting like logo.png inn the temp image folder before so i just uploaded mine and I named it logo.png but not showing at all
Title: Re: Help on images
Post by: Pharg on April 01, 2016, 08:26:53 AM
Opps, I must have given you and very old copy sorry, it's logo.gif I think.

How you find what it's name is to right click and save to see it's name or use firebug in firefox
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 09:47:00 AM
Opps, I must have given you and very old copy sorry, it's logo.gif I think.

How you find what it's name is to right click and save to see it's name or use firebug in firefox
tried that too not working can I give you my ftp login details to see if am doing the wrong thing
Title: Re: Help on images
Post by: Pharg on April 01, 2016, 12:42:37 PM
Hi mafabel,

I have enough to do at the moment with osDateEvo, try and work it out.
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 12:53:18 PM
Hi mafabel,

I have enough to do at the moment with osDateEvo, try and work it out.
OK no problem will try my luck again
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 02:55:27 PM
Tried all my best but no luck site logo only display if I change the template don't know where am doing something wrong
Title: Re: Help on images
Post by: Pharg on April 01, 2016, 09:13:23 PM
Hi mafabel,

I will look for the next version and send it to you.
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 09:28:58 PM
Hi mafabel,

I will look for the next version and send it to you.
ok thanks pharg will be waiting
Title: Re: Help on images
Post by: Pharg on April 01, 2016, 09:52:22 PM
Hi mafabel,

Check your email  ;)
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 10:09:58 PM
Thanks pharg just installed that it solve the logo and banner problem but I just discover profile image not showing until I click
Title: Re: Help on images
Post by: Pharg on April 01, 2016, 10:15:31 PM
Hi mafabel,

Yes I found that issue before also, I have since fixed it, but will have to look for the fix.
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 10:21:23 PM
Hi mafabel,

Yes I found that issue before also, I have since fixed it, but will have to look for the fix.
OK no p I will wait till anytime you are free to teach me the fix
Title: Re: Help on images
Post by: Pharg on April 01, 2016, 10:25:29 PM
Hi mafabel,

In the css folder open the desktop.css and find .smallpic change this:

Code: [Select]
.smallpic {
border: 1px solid #666666;
width: 100px;
height: 100%;
max-height: 150px;
}

To

Code: [Select]
.smallpic {
border: 1px solid #AAA;
max-width: 100px;
width: auto !important;
height: auto !important;
background-size: 120px auto;
min-height: 120px;
max-height: 120px;
overflow: none;
border-radius: 5px;
}


And in the mobile.css find .smallpic and change from:

Code: [Select]
.smallpic {
border: 1px solid #666666;
width: 50px;
height: 100%;
max-height: 75px;
}

To
Code: [Select]
border: 1px solid #AAA;
max-width: 100px;
width: auto;

max-height: 120px;
min-height: 120px;
border-radius: 5px;
 }
Title: Re: Help on images
Post by: mafabel on April 01, 2016, 10:46:05 PM
Thanks it work glad you helped me out one issue again is the the language menu appears twice on my page which make the site have a very large blank page at the bottom but it only occur if am on web browser but my site is fine on mobile
Title: Re: Help on images
Post by: Pharg on April 02, 2016, 12:23:53 AM
Hi mafabel,

Search the forum on how to hide it on login.

I don't see in these pics that it is there twice??
Title: Re: Help on images
Post by: mafabel on April 02, 2016, 03:29:26 AM
Thanks I search through the forum I couldn't find something to solve it all I see is how to hide the language menu itself...check the image below to see what exactly I mean
Title: Re: Help on images
Post by: Pharg on April 02, 2016, 03:56:27 AM
Hi mafabel,

In the rightcolumn.tpl remove the
Code: [Select]
{if $loaded_languages|@count > 1 }
{include file="lang_select.tpl"}
<br />
{/if}

Done, please try to do the rest by reading the forum sorry, I am very busy with EVO
Title: Re: Help on images
Post by: mafabel on April 02, 2016, 04:00:51 AM
OK pharg I will thanks very much
Title: Re: Help on images
Post by: Pharg on April 02, 2016, 04:15:23 AM
Hi mafabel,

Just saw why that was happening, you need to remove this from the index.tpl

Code: [Select]
  <!-- Rightside Column   -->
       <div class="rightcolumn">
{include file="rightcolumn.tpl"}
</div>
Title: Re: Help on images
Post by: mafabel on April 02, 2016, 04:31:20 AM
Thanks all working fine now great work pharg
Title: Re: Help on images
Post by: Pharg on April 02, 2016, 07:02:37 AM
Your welcome