0 Members and 1 Guest are viewing this topic.

*

Fuquan

  • *
  • 2
  • osDate Version: Other
No frontend after installation
« on: July 01, 2018, 10:05:05 AM »
Hi,

I seem to have a weird scenerio as I just downloaded osDate (never heard of it till now so figured I would give it a test run and see if we can use it to replace the one we have as a Joomla component) and the installation went smooth but at the end (after deleting the install folder) the only thing I can reach is the admin panel. Even when you just use the url without the /admin you are still redirected directly to the admin panel. Unfortunately inside osDate admin panel there is no link to the frontend that one can click on (similar to how Joomla works) so gaining access from there is next to impossible.

If anyone knows what may have gone wrong and the possible fix that would be appreciated to hear about.

Thanks
Fuquan
« Last Edit: July 01, 2018, 10:50:00 AM by Pharg »

*

Pharg

  • *****
  • 3,134
    • OsDateFourm
  • osDate Version: osDateEvo v1.3
Re: No frontend after installation
« Reply #1 on: July 01, 2018, 10:59:59 AM »
Hi Fuquan,

What version osDate did you install and on what version of PHP?

OsDate is not similar to Joomla in any way and it doens't have a redirection url in the system anywhere.
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.3 | PHP: 5.3.42 & PHP: 7.1.15 | MySQL: 5.5.35

*

Fuquan

  • *
  • 2
  • osDate Version: Other
Re: No frontend after installation
« Reply #2 on: July 01, 2018, 12:19:29 PM »
Hi Pharg,

Thanks for the prompt feedback. The install was not really the problem (php 7, Ubuntu 16 etc) but rather it was that when the install completed no matter which of the two end of install buttons you pressed it would redirect straight to the "admin" panel. I later (luckily) noticed the logout feature and simply clicked on that and somehow afterwards I was now able to be redirected to the front-end. If anyone else experiences this the trick is to do a clean "logout" using the top button and not close the browser.

That said though may I quickly ask is there is a way to "change" that security code at the bottom of the front-end registration page as it is extremely hard to read or get right (not sure if it is because of my 4k monitors as the whole frontend images also look stretched. I had to try over 12 times to get that security code right and I am sure that would put-off any prospective clients so if there is a way to change it for some other module or even disable it that would be helpful.

Do have a pleasant day
Fuquan

*

Pharg

  • *****
  • 3,134
    • OsDateFourm
  • osDate Version: osDateEvo v1.3
Re: No frontend after installation
« Reply #3 on: July 01, 2018, 12:35:06 PM »
Hi Fuquan,

Yes it's pays to use logouts as the system also uses sessions.

You can use the search the forum to find answers to the security code answers like this:
https://www.osdateforum.com/configuration-installation-4/fixing-osdate-captcha/msg322/#msg322

Or change it to use the google recaptcha
https://www.osdateforum.com/osdateevo-tips-tricks/how-to-remove-the-captcha-and-replace-with-recaptcha-in-signup/msg10072/#msg10072
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.3 | PHP: 5.3.42 & PHP: 7.1.15 | MySQL: 5.5.35