0 Members and 1 Guest are viewing this topic.

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Profile submit failure
« on: May 28, 2016, 07:12:26 PM »
Site updated fine, went and made a new test profile, which created OK. When filling in profile details, all pages went OK on clicking "Submit" except the last one, that page had no content and on clicking submit it gave the following error.

Input array has 1 params, does not match query: 'select id from osdate_sections where displayorder > ? and enabled = ? order by displayorder asc LIMIT 1'

Any idea what is wrong?

TIA
Chris

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Re: Profile submit failure
« Reply #1 on: May 28, 2016, 07:20:49 PM »
Just to be sure, I deleted that profile and started again, same result.

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Re: Profile submit failure
« Reply #2 on: May 28, 2016, 07:42:24 PM »
Just to be sure, I deleted that profile and started again, same result.

Even though I get this error, on investigating the profile, all the info entered on the previous pages has been saved in the profile.

*

Pharg

  • *****
  • 2,789
    • OsDateFourm
  • osDate Version: osDate Evo v1.2
Re: Profile submit failure
« Reply #3 on: May 28, 2016, 10:50:19 PM »
Hi irondutchess,

I had missed some vital files in the osDateEvo Upgrade option sorry  ::)

I have fixed the osDateEvo Upgrade zip file with the added files missing.
You can get the missing files from here https://www.osdateforum.com/osdateevo-configuration-installation/osdateevo-v1-0-upgrade-missing-vital-files/

Sorry once again  :-[
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Re: Profile submit failure
« Reply #4 on: May 29, 2016, 09:56:38 AM »
Uploaded the missing files to the root and admin folder. Still getting the error message at the end of updating profile, also at the top of the page when viewing profile.

Input array has 1 params, does not match query: 'select id from osdate_sections where displayorder > ? and enabled = ? order by displayorder asc LIMIT 1'



Chris

*

Pharg

  • *****
  • 2,789
    • OsDateFourm
  • osDate Version: osDate Evo v1.2
Re: Profile submit failure
« Reply #5 on: May 29, 2016, 10:10:33 AM »
Hello Chris,

Is this running on PHP 5.6 and is this the osDateEvo upgrade version as the pic looks like the old osdate?

Have you tried changing to PHP 5.4 as was announced a day ago also?

-------------------------------------------------------------------------

Just a reminder why I released osDateEvo v1.0.

We have found that it is running perfect on some servers running PHP 5.6 but on other servers like
mine, it has problems being on server strict settings and script Notice warnings, so in this case you will have to have it running on PHP 5.4.

The reason for this seems to be because of the sessions and this is not the only script having
this issue with PHP5.6 as I have checked and there are many other scripts having cookie and session problems also.

Most of you will find it works perfect in PHP 5.6 and others that wont be so lucking,
no problem, just change back to PHP 5.4. as this will be around for a while yet.  ;D

In the mean time, we all can help each other at working out any bugs and fixes that we all find, some will get problems others wont, if we all work together on this we can get a fantastic dating script back on the map. 8)
« Last Edit: May 29, 2016, 10:15:06 AM by Pharg »
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Re: Profile submit failure
« Reply #6 on: May 29, 2016, 11:54:23 AM »
Server is running PHP Version 5.5.32.  Everything else on the site seems to be working OK. No option to change PHP Version.

Chris

*

Pharg

  • *****
  • 2,789
    • OsDateFourm
  • osDate Version: osDate Evo v1.2
Re: Profile submit failure
« Reply #7 on: May 29, 2016, 12:52:09 PM »
Hi Chris,

Thanks for the info.

But, is this the osDateEvo upgrade version??

It looks like an old osDate v2.7 Template.

Did you not rename the old templates before uploading the latest version?
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

Pharg

  • *****
  • 2,789
    • OsDateFourm
  • osDate Version: osDate Evo v1.2
Re: Profile submit failure
« Reply #8 on: May 29, 2016, 10:13:10 PM »
Server is running PHP Version 5.5.32.  Everything else on the site seems to be working OK. No option to change PHP Version.

Chris

Hi Chris,

OsDateEvo is not suppose to have popups enabled for the profiles as it's not mobile friendly.

Please turn it off and see if you still have the same problem?
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Re: Profile submit failure
« Reply #9 on: May 29, 2016, 11:08:37 PM »
Hi,

I renamed the template folder before uploading the update files. Then changed it back after upload. Later realised that I probably should only have done it to the template I was using. Sorted now, with new background image and logo.



Still getting the profile error message. Guess maybe it's down to my having PHP 5.5


Chris

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Re: Profile submit failure
« Reply #10 on: May 29, 2016, 11:11:56 PM »
Server is running PHP Version 5.5.32.  Everything else on the site seems to be working OK. No option to change PHP Version.

Chris

Hi Chris,

OsDateEvo is not suppose to have popups enabled for the profiles as it's not mobile friendly.

Please turn it off and see if you still have the same problem?

I'll try that now.

Which section of the admin is that in?

Chris

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Re: Profile submit failure
« Reply #11 on: May 29, 2016, 11:13:40 PM »
'Use javascript popups for profiles?'  is already set to 'N'

*

Pharg

  • *****
  • 2,789
    • OsDateFourm
  • osDate Version: osDate Evo v1.2
Re: Profile submit failure
« Reply #12 on: May 29, 2016, 11:36:43 PM »
Hi Chris,

I have attached a pic of my profile page and yours, look at the difference.

Something is not setup correct or corrupted in the upload.

Also, try this to see if that error goes away.
In the init.php about line 722 change this:
Code: [Select]
function checkRequestData() {
    $conn = mysqli_connect(DB_HOST, DB_USER, DB_PASS);
    foreach ($_GET as $k => $val) {
        if (! is_array($val)) {
            $val = mysqli_real_escape_string($conn, $val);
        }
        $_GET[$k] = $val;
    }
    foreach ($_POST as $k => $val) {
        if (! is_array($val)) {
            $val = mysqli_real_escape_string($conn, $val);
        }
        $_POST[$k] = $val;
   }

}

Change to:

Code: [Select]
function checkRequestData() {
    $conn = mysql_connect(DB_HOST, DB_USER, DB_PASS);
    foreach ($_GET as $k => $val) {
        if (! is_array($val)) {
            $val = mysql_real_escape_string($conn, $val);
        }
        $_GET[$k] = $val;
    }
    foreach ($_POST as $k => $val) {
        if (! is_array($val)) {
            $val = mysql_real_escape_string($conn, $val);
        }
        $_POST[$k] = $val;
   }

}

Let me know if the error goes away?
« Last Edit: May 29, 2016, 11:52:40 PM by Pharg »
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

irondutchess

  • *
  • 43
    • Date 'n' Meet
  • osDate Version: osDate v2.7
Re: Profile submit failure
« Reply #13 on: May 30, 2016, 09:35:59 AM »
When I changed the code in init.php the site came up OK, but on clicking on 'view profile' the profile page comes up, but has no profile information.

*

Pharg

  • *****
  • 2,789
    • OsDateFourm
  • osDate Version: osDate Evo v1.2
Re: Profile submit failure
« Reply #14 on: May 30, 2016, 10:22:03 AM »
Hi Chris,

Ok, yes it sounds like the popups are still turned on somewhere in the admin area.

Maybe check all the popups stuff in the admin and see what happens?

Let me know if you find something please  ;)
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.2 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35