Update from 2.1.0 to latest?
« on: October 18, 2014, 04:35:27 AM »

I've recently bought a site that runs osdate 2.1.0 and I am not very familiar with the system. The site runs a custom template and I am a bit concerned that something will get messed up if I update to 2.6.5. Can someone help me out with experiences?

« Last Edit: October 18, 2014, 04:51:34 AM by framer »



  • *****
  • 673
    • osDate Forum
Re: Update from 2.1.0 to latest?
« Reply #1 on: October 18, 2014, 11:18:12 AM »
Hi Jan,

Just to note your template will most likely not work, due to changes and would be missing menu options.

To upgrade to the latest version 2.6.5, below is a quick how to

1. Backup your current site, including files and database

2. Go to our download section here: http://www.osdateforum.com/osdate-download-area-20/

3. Download the following:
osDate v2.1.9
osDate v2.5.4
osDate v2.6
osDate v2.6.5

4. Unzip osDate v2.1.9 and upload all the files and folders

5. Run install.php and use the upgrade function

6. Do the same for osDate v2.5.4

7. Unzip osDate v2.6

8. Upload all the files and folders, nothing else to do

9. Unzip osDate v2.6.5

10. Upload all the files and folders, nothing else to do

11. Delete install.php install and install_files

You may want to check and backup after each version been updated.
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll