*

Sil68

  • *
  • 36
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #30 on: March 02, 2014, 10:40:14 AM »
What are your error logs telling you?
Is it saying what you put above

I'm afraid the various log files are simply empty (error.log, php-fpm.log), or containing merely the various URLs called (access.log).
Apache 2.2.22
php-fpm / php  5.4.4-14
MySQL 5.5.31
Debian GNU/Linux 7.0 Wheezy
osDate 2.6

*

CBG

  • *****
  • 673
    • osDate Forum
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #31 on: March 02, 2014, 10:44:25 AM »
Hi,

Give this geoip.inc attached in a .zip a try.
It is a new version.
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

*

Sil68

  • *
  • 36
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #32 on: March 02, 2014, 02:42:27 PM »
Hi,

Give this geoip.inc attached in a .zip a try.
It is a new version.

Just tried it, but I'm afraid to no avail!

When debugging osDate, when reaching line 33 in geoipcity.inc, before being able to actually step into geoip.inc (require_once), the osDate ceases to run, and the WSOD is appearing, hence no chance for me figuring out if and what inside geoip.inc might be causing any issues.
Apache 2.2.22
php-fpm / php  5.4.4-14
MySQL 5.5.31
Debian GNU/Linux 7.0 Wheezy
osDate 2.6

*

Sil68

  • *
  • 36
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #33 on: March 02, 2014, 03:18:39 PM »
When debugging osDate, when reaching line 33 in geoipcity.inc, before being able to actually step into geoip.inc (require_once), the osDate ceases to run, and the WSOD is appearing, hence no chance for me figuring out if and what inside geoip.inc might be causing any issues.

Commenting line 33 in geoipcity.inc lets the programme go on until it is returning to Functions.php, where the next fatality appears to be caused in line 1368 (
Code: [Select]
$gi = geoip_open(GEOIPDATA_DIR."GeoLiteCity.dat",GEOIP_STANDARD);).
Apache 2.2.22
php-fpm / php  5.4.4-14
MySQL 5.5.31
Debian GNU/Linux 7.0 Wheezy
osDate 2.6

*

Sil68

  • *
  • 36
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #34 on: March 02, 2014, 04:15:23 PM »
I've now executed

Code: [Select]
php -l geoip.inc
which resulted in

Code: [Select]
PHP Fatal error:  Cannot redeclare geoip_country_code_by_name() in geoip.inc on line 438
Errors parsing geoip.inc
Apache 2.2.22
php-fpm / php  5.4.4-14
MySQL 5.5.31
Debian GNU/Linux 7.0 Wheezy
osDate 2.6

*

Sil68

  • *
  • 36
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #35 on: March 02, 2014, 05:05:26 PM »
SOLVED!!  :)

Commenting both "function geoip_country_code_by_name" (line 432) and "" (line 448) in geoip.inc did do the trick! That is at least in case the PHP extension geoip is installed! :)
Apache 2.2.22
php-fpm / php  5.4.4-14
MySQL 5.5.31
Debian GNU/Linux 7.0 Wheezy
osDate 2.6

*

pimpi4life

  • *
  • 10
  • im a webdesigner / webmaster
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #36 on: April 01, 2014, 04:01:27 PM »
hello i also have problem with osdate 2.6 cant install it i get blank screen i use


PHP Version 5.4.26
Build Date    Mar 16 2014 00:22:21

i really want to try osdate i dont why this script is not working right

can some one help me?
PHP Version 5.4.26
Build Date    Mar 16 2014 00:22:21

*

Sil68

  • *
  • 36
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #37 on: April 01, 2014, 04:18:47 PM »
For me the issue of the WSOD (white screen of death) arose when having the PHP geoip module installed.

After commenting two lines in osDate's "geoip.inc" (see my previous post) all was just peachy!

Now I'm running osDate 2.6 under php 5.4
Apache 2.2.22
php-fpm / php  5.4.4-14
MySQL 5.5.31
Debian GNU/Linux 7.0 Wheezy
osDate 2.6

*

pimpi4life

  • *
  • 10
  • im a webdesigner / webmaster
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #38 on: April 01, 2014, 04:48:15 PM »
hey man thnx for your reply

i did a fresh install again and its working
so thank god lol

im happy

i just need some nice template now and i can start with osdate for the first time it looks cool :D ;D
PHP Version 5.4.26
Build Date    Mar 16 2014 00:22:21

*

pimpi4life

  • *
  • 10
  • im a webdesigner / webmaster
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #39 on: April 01, 2014, 05:37:07 PM »
damn the script is working i only get a blank page when i click on the editquestions.php

page to edit profile questions how can i fix this? oh i fixed this lol searched at the forum

thnx for so far
« Last Edit: April 01, 2014, 05:39:24 PM by pimpi4life »
PHP Version 5.4.26
Build Date    Mar 16 2014 00:22:21

*

CBG

  • *****
  • 673
    • osDate Forum
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #40 on: April 01, 2014, 05:40:44 PM »
damn the script is working i only get a blank page when i click on the editquestions.php

page to edit profile questions how can i fix this? oh i fixed this lol searched at the forum

thnx for so far

Hi,

See: http://www.osdateforum.com/bugs-9/error-profile-preference-and-fix/
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

*

pimpi4life

  • *
  • 10
  • im a webdesigner / webmaster
Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #41 on: April 01, 2014, 05:43:11 PM »
yesssssssss thanks bro i found it peace lol
PHP Version 5.4.26
Build Date    Mar 16 2014 00:22:21

Re: osdate2.5.4 and 2.6 now fix install on Php 5.2 / Php 5.3 and PHP 5.4
« Reply #42 on: July 08, 2014, 07:51:13 PM »
Help please, how do I install and use the fix "php5.3-5.4.rar" thank you.