New Install - Error After Step 1
« on: April 22, 2015, 06:13:05 AM »
When I begin the install, everything is passed with a "YES". When I click "Continue", I get:

Code: [Select]
Fatal error: Call to undefined function import_request_variables() in ../install.php on line 67
I have installed the newer SQL folder.

Beginning at Line 67 in install.php:

Code: [Select]
import_request_variables( 'pgs' );

define ( 'SMARTY_DIR', $full_path . 'libs/Smarty/' );
define ( 'TEMPLATES_DIR', $full_path . 'templates/' );
define ( 'TEMPLATE_DIR', $full_path . 'templates/' );
define ( 'TEMPLATE_C_DIR', $full_path . 'temp/templates_c/' );
define ( 'PEAR_DIR', $full_path . 'libs/Pear/' );
define ( 'CACHE_DIR', $full_path . 'temp/cache/' );
define ( 'INCLUDE_DIR', $full_path . 'includes/' );
define ( 'DOC_ROOT', $full_path );
// define ( 'LANG_DIR', $full_path . 'language/' );

require_once SMARTY_DIR . 'Config_File.class.php';
require_once SMARTY_DIR . 'Smarty.class.php';
require_once INCLUDE_DIR . 'internal/Functions.php';

//ini_set( 'include_path', PEAR_DIR );

require_once( PEAR_DIR . 'DB.php' );

// PEAR::setErrorHandling( PEAR_ERROR_CALLBACK, 'errhndl' );

« Last Edit: April 22, 2015, 06:24:41 AM by TE5LA »

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: New Install - Error After Step 1
« Reply #1 on: April 22, 2015, 06:44:59 AM »
Hi TE5LA,

This tells me you are trying to install on PHP 5.5 or higher which the installer wont work in.

What version osDate do you have and what are your host specs as you will see in my signature below?
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

Re: New Install - Error After Step 1
« Reply #2 on: April 22, 2015, 02:31:27 PM »
Thanks for your reply.

You are correct. It seems the php version is listed as "5". I do not know if it's 5.x or whatever. The host has not yet answered me. PERL is listed as 5.12. osDate version is 2.54.

I am not so good at coding but I am good at Search Engine :)   I was able to modify files to get up to step_4.php where you enter the DB credentials, but trying to go past that threw an error. I don't remember exactly what it was. That is when I discovered there was a new SQL folder so I abandoned it and put the original files back and started over.

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: New Install - Error After Step 1
« Reply #3 on: April 22, 2015, 09:58:58 PM »
Hi TE5LA,


You can get the latest osdate v265 from here http://www.osdateforum.com/osdate-download-area-20/

« Last Edit: April 23, 2015, 01:25:50 AM by Pharg »
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

Re: New Install - Error After Step 1
« Reply #4 on: April 22, 2015, 11:09:09 PM »
Is that version supposed to be compatible with the newer php?

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: New Install - Error After Step 1
« Reply #5 on: April 23, 2015, 12:43:49 AM »
Hi TE5LA,

Yes but I would recommend PHP 5.4 even though it will run ok in PHP 5.5
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

Re: New Install - Error After Step 1
« Reply #6 on: April 23, 2015, 01:07:49 AM »
Hopefully my host will be able to do this. Still waiting on exactly what version they use.

If I want to integrate FlashChat, what is the best (most compatible) version?

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: New Install - Error After Step 1
« Reply #7 on: April 23, 2015, 01:14:24 AM »
Hi

The last FlashChat ever made was  FlashChat 6.08 being the lastest version.
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

Re: New Install - Error After Step 1
« Reply #8 on: April 23, 2015, 01:17:09 AM »
Thanks, and that new version of osDate installed perfectly.

Thanks for the help. Will probably add FlashChat and phpBB3.

Re: New Install - Error After Step 1
« Reply #9 on: April 23, 2015, 01:19:55 AM »
However, it will not let me login as admin. How do I find the credentials in files?

Or is there a different URL for admin?

Answered my own question :)  I got it.
« Last Edit: April 23, 2015, 01:27:56 AM by TE5LA »

Re: New Install - Error After Step 1
« Reply #10 on: April 23, 2015, 02:07:22 AM »
Got this error at step 2 trying to install FlashChat 6.0.8:

Code: [Select]
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes) in ../init.php on line 334

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: New Install - Error After Step 1
« Reply #11 on: April 23, 2015, 03:02:00 AM »
Hi TE5LA,

I posted the fix here www.osdateforum.com/flashchat/fix-for-flashchat-6-0-8-install/

Please use the search, there are many updates on here  ;)
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35