*

sferentzi

Error while installing osDate v2.6 and v2.54
« on: January 30, 2013, 01:34:57 PM »
I got the error message attached.
Has somebody any idea, how to solve the problem?
Thx.

*

CBG

  • *****
  • 673
    • osDate Forum
Re: Error while installing osDate v2.6 and v2.54
« Reply #1 on: January 30, 2013, 04:39:02 PM »
Hi,

Are you running PHP 5.3 or over?
If so in PHP 5.3 it became deprecated and removed in PHP 5.4.

Try this, open up the install.php file, find:

import_request_variables
change to:
extract

Let me know if that fixes the problem or not
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

*

sferentzi

Re: Error while installing osDate v2.6 and v2.54
« Reply #2 on: February 01, 2013, 08:15:28 AM »
Hi,

thanks for the idea.

It worked, I changed the code to this:
$osDateInstall_array = array("a" => "p","b" => "g", "c" => "s");
extract($osDateInstall_array);

But it doesn't work correctly, I have other error messages.

Have you aní idea ? :)

Thanks.



*

CBG

  • *****
  • 673
    • osDate Forum
Re: Error while installing osDate v2.6 and v2.54
« Reply #3 on: February 01, 2013, 10:22:41 AM »
Open: libs\Pear\DB.php

Change line 311 to:
Code: [Select]
@$obj = new $classname;

Change line 384 to:
Code: [Select]
@$obj = new $classname;

Change line 889 to:
Code: [Select]
$arr = new $object_class($arr);

Second screenshot couldn't see any errors

There maybe other errors like in screenshot one, it could be a similar problem with just changing =& or = & to =

These PHP errors are down to PHP 5.3.x and upwards.
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

*

sferentzi

Re: Error while installing osDate v2.6 and v2.54
« Reply #4 on: February 03, 2013, 05:26:44 PM »
Hi,

thanks for your help, it worked, but I have the next step full of error messages. :(

https://picasaweb.google.com/100288943484020184400/OsDateInstall?authuser=0&feat=directlink

Thx,
Sandor

*

CBG

  • *****
  • 673
    • osDate Forum
Re:  Error while installing osDate v2.6 and v2.54
« Reply #5 on: February 03, 2013, 05:37:35 PM »
Hi,

Never seen those errors before, what version of PHP and MySQL are you using?
What version of XAMPP are you using?

Also have you tried to content you and ignoring those errors?
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

*

sferentzi

Re: Error while installing osDate v2.6 and v2.54
« Reply #6 on: February 05, 2013, 01:30:54 PM »
I am using:
XAMPP: 1.8.1
PHP: 5.4.7
MySQL: 5.5.27

*

CBG

  • *****
  • 673
    • osDate Forum
Re: Error while installing osDate v2.6 and v2.54
« Reply #7 on: February 07, 2013, 07:09:08 PM »
Hi,

I will see if I can install XAMPP this weekend and test it out.
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

*

sferentzi

Re: Error while installing osDate v2.6 and v2.54
« Reply #8 on: February 08, 2013, 03:15:16 PM »
Hi,

thanks a lot.

On which MySQL / PHP version is osDate surely runnig?

*

mrmrs

  • *
  • 45
Re: Error while installing osDate v2.6 and v2.54
« Reply #9 on: February 09, 2013, 01:23:08 PM »
tried installing osdate on 2 seperate hosting account and get the following error on building tables what do i have to do to solve this error is below
osDate 2.5 Installer - Fresh Install
Database connection successful.
Step 4: Database creation and system and sample data loading
Writing installation parameters to config.php file... Done
Creating new tables...
    Creating table : osdate_admin ... Failed
    Creating table : osdate_admin_permissions ... Failed
    Creating table : osdate_adminemails ... Failed
    Creating table : osdate_aff_referals ... Failed
    Creating table : osdate_affiliates ... Failed
    Creating table : osdate_articles ... Failed
    Creating table : osdate_banners ... Failed
    Creating table : osdate_blog_comments ... Failed
    Creating table : osdate_blog_preferences ... Failed
    Creating table : osdate_blog_story ... Failed
    Creating table : osdate_blog_vote ... Failed
    Creating table : osdate_buddy_ban_list ... Failed
    Creating table : osdate_calendars ... Failed
    Creating table : osdate_calendarevents ... Failed
    Creating table : osdate_calendarwatchevents ... Failed
    Creating table : osdate_cities ... Failed
    Creating table : osdate_counties ... Failed
    Creating table : osdate_countries ... Failed
    Creating table : osdate_featured_profiles ... Failed
    Creating table : osdate_glblsettings ... Failed
    Creating table : osdate_imported_users ... Failed
    Creating table : osdate_import_questions_xref ... Failed
    Creating table : osdate_instant_message ... Failed
    Creating table : osdate_languages ... Failed
    Creating table : osdate_letters ... Failed
    Creating table : osdate_log ... Failed
    Creating table : osdate_mailbox ... Failed
    Creating table : osdate_membership ... Failed
    Creating table : osdate_news ... Failed
    Creating table : osdate_onlineusers ... Failed
    Creating table : osdate_pages ... Failed
    Creating table : osdate_payment_config ... Failed
    Creating table : osdate_payment_modules ... Failed
    Creating table : osdate_plugin ... Failed
    Creating table : osdate_plugin_access ... Failed
    Creating table : osdate_plugin_config ... Failed
    Creating table : osdate_plugin_tables ... Failed
    Creating table : osdate_pollips ... Failed
    Creating table : osdate_polloptions ... Failed
    Creating table : osdate_polls ... Failed
    Creating table : osdate_poll_answer ... Failed
    Creating table : osdate_poll_option ... Failed
    Creating table : osdate_poll_question ... Failed
    Creating table : osdate_promo ... done
    Creating table : osdate_promo_used ... done
    Creating table : osdate_questionoptions ... Failed
    Creating table : osdate_questions ... Failed
    Creating table : osdate_ratings ... Failed
    Creating table : osdate_sections ... Failed
    Creating table : osdate_shoutbox ... Failed
    Creating table : osdate_states ... Failed
    Creating table : osdate_stories ... Failed
    Creating table : osdate_transactions ... Failed
    Creating table : osdate_user ... Failed
    Creating table : osdate_user_watched_profiles ... Failed
    Creating table : osdate_user_actions ... Failed
    Creating table : osdate_useralbums ... Failed
    Creating table : osdate_user_choices ... done
    Creating table : osdate_userpreference ... Failed
    Creating table : osdate_userrating ... Failed
    Creating table : osdate_usersearches ... Failed
    Creating table : osdate_usersnaps ... Failed
    Creating table : osdate_usertemplates ... Failed
    Creating table : osdate_uservideos ... Failed
    Creating table : osdate_views_winks ... Failed
    Creating table : osdate_zips ... Failed
    Creating table : osdate_mails ... Failed
Failed
Process to create tables in the database failed. It could be because of incompatible type or insufficient space. If any tables are created, drop those tables. Please check and restart installation process

*

CBG

  • *****
  • 673
    • osDate Forum
Re: Error while installing osDate v2.6 and v2.54
« Reply #10 on: February 10, 2013, 03:59:46 PM »
Hi,

thanks a lot.

On which MySQL / PHP version is osDate surely runnig?
I have had it working on PHP 5.3.x, and MySQL 5.x with the MySQL patch in the configuration forum.
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

*

KJZ

  • *
  • 2
Re: Table creation errors while installing osDate v2.6 with php 5.4.19
« Reply #11 on: September 01, 2013, 11:39:41 PM »
I am placing this in a new topic, although the problem has been mentioned, but apparently not solved, at the beginning  of this year by sferentzi and mrmrs (sferentzi- last post Feb 10) 

I've applied all the fixes mentioned on this board (the .SQL files and the php code modifications)

I've tested this with a recent XAMP version, which uses the same php version (5.4.19) as my hoster.

The signaled strict standard problems and warnings preceding the creation of tables are the same as those shown by sferentzi.

The subsequent table creation fails:

For each table, the following problems are mentioned:

Strict Standards: Non-static method DB::isManip() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\osDate\libs\Pear\DB\mysql.php on line 207

Strict Standards: Non-static method DB::errorMessage() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\osDate\libs\Pear\DB.php on line 748

Strict Standards: Non-static method DB::isError() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\osDate\libs\Pear\DB.php on line 526

Strict Standards: Non-static method PEAR::getStaticProperty() should not be called statically, assum-ing $this from incompatible context in C:\xampp\htdocs\osDate\libs\Pear\PEAR.php on line 871

Then there is the following message followed by a "Failed" notice and the table isn't created:

Strict Standards: Non-static method DB::isError() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\osDate\libs\Pear\DB\common.php on line 1155
Failed


*

KJZ

  • *
  • 2
Re: Error while installing osDate v2.6 and v2.54
« Reply #12 on: September 01, 2013, 11:43:34 PM »
As I see, my post  has been placed in the old topic - I am new here  :)

*

Pharg

  • *****
  • 2,065
  • osDate Version: osDate Evo v1.0
Re: Error while installing osDate v2.6 and v2.54
« Reply #13 on: September 02, 2013, 11:16:21 AM »
Hi CBG,

Please let me know how you go with php 5.4 as I tried it and got loads of problems, Cheers

Hi,

I will see if I can install XAMPP this weekend and test it out.
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

Re: Error while installing osDate v2.6 and v2.54
« Reply #14 on: September 10, 2013, 07:04:57 PM »
Like to know too even more problems than with 5.3
« Last Edit: September 11, 2013, 06:53:55 PM by oppeneer »
Kind regards,

Jan Oppeneer
working on template for 2.6 and OsdatePDO

My sites under construction:

www.oudere-homo-mannen.com
www.homosenioren.com
www.hotdatingplanet.eu

Will be testing for Osdater.