Blank Page on Step 1
« on: March 29, 2015, 03:10:18 PM »
Hello,

I just installed OSdate and when I run the install.php, it shows everything is okay to continue, then when I click continue, I get a blank page on step 1. How do I fix this? I'm running php 5.5.9.

Thanks,
Dan

*

CBG

  • *****
  • 673
    • osDate Forum
Re: Blank Page on Step 1
« Reply #1 on: March 29, 2015, 03:17:07 PM »
Hi Dan,

While osDate should work on PHP 5.5.X, the installer does not, are you able to change your PHP version to PHP 5.3.x or PHP 5.4.x?
Also what version of osDate are you installing (if you got it from tufat.com it will be osDate 2.5.4) as osDate 2.6.5, should install on PHP 5.3.x and PHP 5.4.x.

We are hoping to sort this, but don't have a date as this time.
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

Re: Blank Page on Step 1
« Reply #2 on: March 30, 2015, 03:04:47 AM »
Hello,

Thank you for your reply. II am unable to change php due to other sites that I am running using the current 5.5.X. Is there another way to get around the installer using my current configuration? or should I just wait for an update? I did get the script off of tufat, so it is 2.54. Where do I get the 2.65?

Thanks,
Dan

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: Blank Page on Step 1
« Reply #3 on: March 30, 2015, 03:35:31 AM »
Hello,

Thank you for your reply. II am unable to change php due to other sites that I am running using the current 5.5.X. Is there another way to get around the installer using my current configuration? or should I just wait for an update? I did get the script off of tufat, so it is 2.54. Where do I get the 2.65?

Thanks,
Dan

Hi Dan,

You can get osDate 2.6.5 from here http://www.osdateforum.com/osdate-download-area-20/osdate-v2-6-5-download-%28current-version%29/
You will still need php 5.3 or 5.4 to install this with the installer.

Most hosts will allow you to change to earlier versions of PHP 5, check in the Cpanel under PHP

« Last Edit: March 30, 2015, 03:46:00 AM by Pharg »
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

Re: Blank Page on Step 1
« Reply #4 on: March 30, 2015, 04:54:04 AM »
Does your hosting in the cpanel let you set php to 5.4? In changing this it will not make any other sites you have stop working it will only give you the ability to install 2.65 as Pharg gave you a link to. Osdate currently works up to version 5.9beta just the installer doesn't work.

Re: Blank Page on Step 1
« Reply #5 on: March 31, 2015, 02:54:35 AM »
I don't believe I can change the php version, but i'll check it out. Thank you for your reply.

Re: Blank Page on Step 1
« Reply #6 on: March 31, 2015, 03:21:13 AM »
I just tried the latest version and it installed just fine on php 5.5.9  Thanks, Dan

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: Blank Page on Step 1
« Reply #7 on: March 31, 2015, 04:09:28 AM »
I just tried the latest version and it installed just fine on php 5.5.9  Thanks, Dan

Hi bazoodle,

Thanks for letting me know, Sometimes this happens because of different settings in php version by the host.

I last tested this on php 5.6 localhost on my computer and the installer failed on the localhost, I haven't tested online as my host doesn't have that version php running yet.

If you run into any problems running the script, please let me know.
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

Re: Blank Page on Step 1
« Reply #8 on: March 31, 2015, 12:35:04 PM »
So far the only thing I found is that the url by name doesn't work even though I have mod_rewrite enabled. I will do more testing later today. Here is what I have it installed on.

*

CBG

  • *****
  • 673
    • osDate Forum
Re: Blank Page on Step 1
« Reply #9 on: March 31, 2015, 12:47:40 PM »
Have you set the .htaccess file up? and the path to where osDate is, in the .htaccess file?

The RewriteBase /osDate_v265/ need to be set where osDate is.

Code: [Select]
RewriteEngine on

# Replace with site url prefix. If osdate is in your site root, set this to just / symbol
# If osdate is in a subdirectory, set to /subdirectory/

RewriteBase /osDate_v265/

RewriteRule ^privacy.html$ index.php?page=privacy
RewriteRule ^terms_of_use.html$ index.php?page=terms_of_use
RewriteRule ^services.html$ index.php?page=services
RewriteRule ^faq.html$ index.php?page=faq

RewriteRule ^stories.html$ index.php?page=stories
RewriteRule ^story([^/]+).htm$ index.php?page=showstory&storyid=$1

RewriteRule ^articles.html$ index.php?page=articles
RewriteRule ^article([^/]+).htm$ index.php?page=showarticle&articleid=$1

RewriteRule ^news([^/]+).htm$ index.php?page=shownews&newsid=$1
RewriteRule ^allnews.html$ index.php?page=allnews

# Translates sitename/username to sitename/showprofile.php?username=username
RewriteRule ^([a-zA-Z0-9_-]+)$ showprofile.php?username=$1

# Translates {$id}.htm to showprofile.php?id={$id}
RewriteRule ^([^/]+).htm$ showprofile.php?id=$1
« Last Edit: March 31, 2015, 12:49:47 PM by CBG »
Regards,
CBG (Garry)
osDate: 2.6.5, 2.7 & Evo
PHP: 5.5.x/5.6.x (5.3.x to 5.6.x) | MySQL: 5.5.34-cll

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: Blank Page on Step 1
« Reply #10 on: March 31, 2015, 12:55:10 PM »
You need to remove the osdatev265/ from the .htaccess just leaving the /
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35