*

Burton

  • ***
  • 128
Re: Help please - Deprecated Lines on Instalation
« Reply #45 on: February 03, 2015, 06:29:03 AM »
Hi Phil,

Ok I understand,

I would like Private Photo Albums working, as it is a nice carrot in Upgrade Options,

But until that happens I will remove it from Membership Options and Upgrade Comparisons,

Don't want to promise things that are not working 100%

If you or anyone else does find a fix please let me know,

many thank yous Phil  :)


*

Burton

  • ***
  • 128
Re: Help please - Deprecated Lines on Instalation
« Reply #46 on: February 04, 2015, 12:50:31 AM »
Hi Phil,

I have made some changes to the lang_english/profile_questions.php

How do I update/upload this into the system, so the changes show on the site?

your help always appreciated :)

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: Help please - Deprecated Lines on Instalation
« Reply #47 on: February 04, 2015, 01:46:12 AM »
Hi Phil,

I have made some changes to the lang_english/profile_questions.php

How do I update/upload this into the system, so the changes show on the site?

your help always appreciated :)

Hi Burton,

You load them the same way you load the lang_main.php in the admin in the loading language.
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

Burton

  • ***
  • 128
Re: Help please - Deprecated Lines on Instalation
« Reply #48 on: February 04, 2015, 02:07:07 AM »
Hi Phil,

I dont understand, when I go to admin/manage languages, then I select English

But I can not choose from lang_main.php or profile_questuions.php

So when I click Load Language it must just/only load the lang_main.php

Is that correct? or does it load both php's ? or am I missing something?


*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: Help please - Deprecated Lines on Instalation
« Reply #49 on: February 04, 2015, 02:11:26 AM »
Hi Phil,

I dont understand, when I go to admin/manage languages, then I select English

But I can not choose from lang_main.php or profile_questuions.php

So when I click Load Language it must just/only load the lang_main.php

Is that correct? or does it load both php's ? or am I missing something?



Hi Burton,

It loads both those files into the language, just click load and it should be done.
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

Burton

  • ***
  • 128
Re: Help please - Deprecated Lines on Instalation
« Reply #50 on: February 04, 2015, 02:18:21 AM »
Hi Phil,

Ok thank you, yet at the moment those language changes are not showing on the site,

I will keep playing :)

*

Burton

  • ***
  • 128
Re: Help please - Deprecated Lines on Instalation
« Reply #51 on: February 04, 2015, 03:12:29 AM »
Hi Phil,

Can I select English language, the click Remove from DB

Then re-slect English and click Load Language?

Would that help in the loading the new/revised profile_questions.php?

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: Help please - Deprecated Lines on Instalation
« Reply #52 on: February 04, 2015, 03:30:56 AM »
Hi Phil,

Can I select English language, the click Remove from DB

Then re-slect English and click Load Language?

Would that help in the loading the new/revised profile_questions.php?


Hi Burton,

No don't do that, you will end up with no language loaded.
Question, Why aren't you adding your profile questions in the admin/ Section Management which saves into the database?
« Last Edit: February 04, 2015, 03:34:21 AM by Pharg »
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

Burton

  • ***
  • 128
Re: Help please - Deprecated Lines on Instalation
« Reply #53 on: February 04, 2015, 05:25:45 AM »
Hi Phil,

Ok so I did an experiment,

Modified some words in language_main.php - then re-loaded in Admin - Yes changes show on the site.

Modified some words in profile_questions.php the re-loaded in Admin - No changes show on site.

So I deduct from this that the profile_questions.php is not being re-loaded.

For example: "Referred by:" line 1535 in my profile_questions.php I changed "Referred by:" to "NewWords:"

then re-loaded in Admin - No changes show on site. Nothings happens,  "Referred by:" continues to show.

I am not adding questions, as I am modifying the wording on existing questions.

Is there another way to make this profile_questions.php re-load the new words ?

you time and help greatly appreciated Phil  :)

Ps:  So in Section Management if I select "Interests" then click Reset - does that allow editing? or delete all?
« Last Edit: February 04, 2015, 05:34:13 AM by Burton »

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: Help please - Deprecated Lines on Instalation
« Reply #54 on: February 04, 2015, 07:20:28 AM »
Hi Phil,

Ok so I did an experiment,

Modified some words in language_main.php - then re-loaded in Admin - Yes changes show on the site.

Modified some words in profile_questions.php the re-loaded in Admin - No changes show on site.

So I deduct from this that the profile_questions.php is not being re-loaded.

For example: "Referred by:" line 1535 in my profile_questions.php I changed "Referred by:" to "NewWords:"

then re-loaded in Admin - No changes show on site. Nothings happens,  "Referred by:" continues to show.

I am not adding questions, as I am modifying the wording on existing questions.

Is there another way to make this profile_questions.php re-load the new words ?

you time and help greatly appreciated Phil  :)

Ps:  So in Section Management if I select "Interests" then click Reset - does that allow editing? or delete all?

Hi Burton,

Adding Editing renaming etc is all done in the Section Management as it shows in there.
You can add more sections or questions, you can disable or delete them to how you want.

As far as I know, adding to the profile_questions.php doesn't work as there doesn't seem to be a way to upload the changes
to the database unless you make a new database add on.
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35

*

Burton

  • ***
  • 128
Re: Help please - Deprecated Lines on Instalation
« Reply #55 on: February 04, 2015, 07:45:17 AM »
Fantastic Phil :)

Yes you can change the profiles_questions.php, but can not upload it to the DB.

But now I am editing using the Section Management, it is working easily :)  Thank you Phil.

So a new little problem created by TinyMCE editor, it places a rn between my lines.

This is line one,

rn

This is line two.

I am reading that this problem has happened to others here:

http://www.tinymce.com/forum/viewtopic.php?id=15219

have you seen this Phil?   :)

*

Burton

  • ***
  • 128
Re: Help please - Deprecated Lines on Instalation
« Reply #56 on: February 04, 2015, 11:16:01 AM »
Hi Phil,

It seems I need to add some code into TintMCE to stop the rn

http://www.tinymce.com/forum/viewtopic.php?id=24299

stripslashes(str_replace('\r\n', '', mysql_real_escape_string($_post['description'])))

Where to place this code Phil?  within all the many TinyMCE files?

*

Pharg

  • *****
  • 2,071
  • osDate Version: osDate Evo v1.0
Re: Help please - Deprecated Lines on Instalation
« Reply #57 on: February 04, 2015, 11:32:47 AM »
Fantastic Phil :)

Yes you can change the profiles_questions.php, but can not upload it to the DB.

But now I am editing using the Section Management, it is working easily :)  Thank you Phil.

So a new little problem created by TinyMCE editor, it places a rn between my lines.

This is line one,

rn

This is line two.

I am reading that this problem has happened to others here:

http://www.tinymce.com/forum/viewtopic.php?id=15219

have you seen this Phil?   :)

Hi Burton,

Firstly I already said the profiles_questions.php can be edited but you can't use it to upload to the database!!!

As for the \rn\ try changing your database to utf8 using the script I have attached, upload it to the admin side and then type the
name of it into the address bar being admin/changeDB_to_utf8.php the hit enter.

Once this is done, delete it. Check you database has change, the \rn\ issue should be gone.

I am going to move these posts to the bugs area and lock it, to many questions in the wrong area of the forum.
Please post your questions in the correct posts from now on!!
« Last Edit: February 04, 2015, 11:35:01 AM by Pharg »
Regards,
Pharg ( Phill )

REMEMBER: ALWAYS BACKUP BEFORE YOU MAKE ANY CHANGES!!

osDateEvo v1.0 | PHP: 5.3.42 & PHP: 5.6.18 | MySQL: 5.5.35